Civil Rights
Movements, leaders, victories and the continuing fight for equality.
Explore the people, places, events, achievements, struggles and stories that shaped our journey.
Movements, leaders, victories and the continuing fight for equality.
Innovation, patents, science, technology and world-changing contributions.
Pioneers, champions, Negro Leagues, records, activism and excellence.
Meet the people whose lives, choices and achievements shaped the journey.
Black towns, communities, institutions and places where history happened.
Moments that changed communities, movements, institutions and the nation.
In August 1908, a white mob attacked Springfield, Illinois’s Black community, destroying homes and businesses and lynching two Black men. National outrage over the violence helped spur the movement that created the NAACP the following year.
MORE →Reflects the personal views, recollections, and perspective of the author, Mike Davis.
This is a personal recollection on the Move fire on May 13, 1985
This article has multiple issues. Please help improve it or discuss these issues on the talk page. (Learn how and when to remove these messages)
|
| Communication protocol | |
| OSI layer | Application |
|---|---|
| Ports | 80, 443 |
| RFCs | RFC 2518, RFC 4918 |
| Website | www |
WebDAV (Web Distributed Authoring and Versioning) is a set of extensions to the Hypertext Transfer Protocol (HTTP) allowing user agents to collaboratively edit content directly in an HTTP server, which may act as a file server. It provides facilities for concurrency control and namespace operations, thus allowing the Web to be viewed as a writeable medium and not just a read-only medium.[1] WebDAV is defined in RFC 4918 by a working group of the Internet Engineering Task Force (IETF).[2]
The WebDAV protocol provides a framework for users to create, change and move documents on a server. The most important features include the maintenance of properties about an author or modification date, namespace management, collections, and overwrite protection. Maintenance of properties includes such things as the creation, removal, and querying of file information. Namespace management deals with the ability to copy and move web pages within a server's namespace. Collections deal with the creation, removal, and listing of various resources. Lastly, overwrite protection handles aspects related to the locking of files. It takes advantage of existing technologies such as Transport Layer Security, digest access authentication or XML to satisfy those requirements.[3]
Modern operating systems such as GNOME Desktop Environment for Linux provide built-in client-side support for WebDAV.[4]
WebDAV began in 1996 when Jim Whitehead worked with the World Wide Web Consortium (W3C) to host two meetings to discuss the problem of distributed authoring on the World Wide Web with interested people.[5][6] Tim Berners-Lee's original vision of the Web involved a medium for both reading and writing. In fact, Berners-Lee's first web browser, called WorldWideWeb, could both view and edit web pages; but, as the Web grew, it became a read-only medium for most users. Whitehead and other like-minded people wanted to transcend that limitation.[7][8]
The meetings resulted in the formation of an IETF working group because the new effort would lead to extensions to HTTP, which the IETF had started to standardize.
As work began on the protocol, it became clear that handling both distributed authoring and versioning together would involve too much work and that the tasks would have to be separated. The WebDAV group focused on distributed authoring, and left versioning for the future. (The Delta-V extension added versioning later – see the Extensions section below.)
The WebDAV working group concluded its work in March 2007, after the Internet Engineering Steering Group (IESG) accepted an incremental update to RFC 2518. Other extensions left unfinished at that time, such as the BIND method, have been finished by their individual authors, independent of the formal working group.[9]

WebDAV extends the set of standard HTTP verbs and headers allowed for request methods. The added verbs include:
| Verb | Action |
|---|---|
| COPY | copy a resource from one uniform resource identifier (URI) to another |
| LOCK | put a lock on a resource. WebDAV supports both shared and exclusive locks. |
| MKCOL | create collections (also known as a directory) |
| MOVE | move a resource from one URI to another |
| PROPFIND | retrieve properties, stored as XML, from a web resource. It is also overloaded to allow one to retrieve the collection structure (also known as directory hierarchy) of a remote system. |
| PROPPATCH | change and delete multiple properties on a resource in a single atomic act |
| UNLOCK | remove a lock from a resource |
The properties of WebDAV protocol are name–value pair, in which a "name" is a Uniform Resource Identifier (URI) and the "values" are expressed through XML elements. Furthermore, the methods to handle the properties are PROPFIND and PROPPATCH.[10]
The WebDAV working group produced several works:
For versioning, the Delta-V protocol under the Web Versioning and Configuration Management working group adds resource revision tracking, published in RFC 3253.
For searching and locating, the DAV Searching and Locating (DASL) working group never produced any official standard although there are a number of implementations of its last draft. Work continued as non-working-group activity.[11] The WebDAV Search specification attempts to pick up where the working group left off, and was published as RFC 5323 in November 2008.[12]
For calendaring, CalDAV is a protocol allowing calendar access via WebDAV. CalDAV models calendar events as HTTP resources in iCalendar format, and models calendars containing events as WebDAV collections.
For groupware, GroupDAV is a variant of WebDAV which allows client/server groupware systems to store and fetch objects such as calendar items and address book entries instead of web pages.
For MS Exchange interoperability, WebDAV can be used for reading/updating/deleting items in a mailbox or public folder. WebDAV for Exchange has been extended by Microsoft to accommodate working with messaging data. Exchange Server version 2000, 2003, and 2007 support WebDAV. However, WebDAV support has been discontinued in Exchange 2010[13] in favor of Exchange Web Services (EWS), a SOAP/XML based API.
As part of the Windows Server Protocols (WSPP) documentation set,[14] Microsoft published the following protocol documents detailing extensions to WebDAV:
| Client | Creator | Operating system support | License | Interface |
|---|---|---|---|---|
| Cyberduck | David V. Kocher | Windows, macOS | GPL | GUI |
| davfs2 | GNOME team | FUSE | GPL | VFS |
| davix | CERN | Windows, Linux, macOS | LGPL | CLI |
| EasySync | Samuel CHEMLA | Android | MIT | Service |
| DAVx⁵ | BitfireAT | Android | GPL | Service |
| Finder[19] | Apple | macOS | Proprietary | GUI |
| X-plore | Lonely Cat Games | Android | Proprietary | GUI |
| GVfs | GNOME team | GNOME | GPL | VFS |
| KIO | KDE team | KDE | GPL | VFS |
| Konqueror | KDE team | KDE | GPL | GUI |
| GNOME Files | GNOME team | GNOME | GPL | GUI |
| SmartFTP | SmartSoft Ltd | Windows | Proprietary | GUI |
| WebDrive | South River Technologies | Windows, macOS, iOS, Android | Proprietary | VFS |
| WinSCP | Martin Přikryl | Windows | GPL | CLI and GUI |
| WebClient (Deprecated)[20] | Microsoft | Windows | Same as Windows | service |
| Mountain Duck | iterate GmbH | Windows, macOS | Proprietary | VFS |
| Cyberduck CLI | iterate GmbH | Windows, macOS, Linux | Proprietary | CLI |
| CloudMounter | Electronic Team, Inc. | Windows, macOS | Proprietary | GUI |
| Libraries | Creator | Operating system or platform | License | Language |
|---|---|---|---|---|
| Apache Wink | Apache Software foundation | JVM | Java | |
| Apache Tomcat | Apache Software foundation | JVM | Java | |
| Apache Jackrabbit | Apache Software foundation | JVM | ASF | Java |
| sabre/dav | fruux | Windows, Linux, macOS | New BSD | PHP |
Source: Wikipedia. Article content is retrieved live through the MediaWiki API.
The Maintenance Operation Protocol (MOP) is used for utility services such as uploading and downloading system software, remote testing and problem diagnosis. It was a proprietary protocol of Digital Equipment Corporation. MOP frames can be one of the following commands:
Operations, administration, and management or operations, administration, and maintenance (OA&M or OAM) are the processes, activities, tools, and standards involved with operating, administering, managing and maintaining any system. This commonly applies to telecommunication, computer networks, and computer hardware. In particular, Ethernet operations, administration and maintenance (EOAM) is the protocol for installing, monitoring and troubleshooting Ethernet metropolitan area network (MANs) and Ethernet WANs. The OAM features covered by this protocol are discovery, link monitoring, remote fault detection and remote loopback.
WebDAV (Web Distributed Authoring and Versioning) is a set of extensions to the Hypertext Transfer Protocol (HTTP) allowing user agents to collaboratively edit content directly in an HTTP server, which may act as a file server. It provides facilities for concurrency control and namespace operations, thus allowing the Web to be viewed as a writeable medium and not just a read-only medium. WebDAV is defined in RFC 4918 by a working group of the Internet Engineering Task Force (IETF). The WebDAV protocol provides a framework for users to create, change and move documents on a server. The most important features include the maintenance of properties about an author or modification date, namespace management, collections, and overwrite protection. Maintenance of properties includes such things as the creation, removal, and querying of file information. Namespace management deals with the ability to copy and move web pages within a server's namespace. Collections deal with the creation, removal, and listing of various resources. Lastly, overwrite protection handles aspects related to the locking of files. It takes advantage of existing technologies such as Transport Layer Security, digest access authentication or XML to satisfy those requirements. Modern operating systems such as GNOME Desktop Environment for Linux provide built-in client-side support for WebDAV.
The Protocol on Ireland/Northern Ireland, commonly abbreviated to the Northern Ireland Protocol (NIP), is a protocol to the Brexit withdrawal agreement that sets out Northern Ireland’s post-Brexit relationship with both the EU and Great Britain. The Withdrawal Agreement, including the Protocol, came into effect on 1 January 2021. Citing the island of Ireland's "unique circumstances", the Protocol governs unique arrangements on the island between the United Kingdom and the European Union; it regulates some aspects of trade in goods between Northern Ireland and the rest of the United Kingdom. The Protocol's arrangements, under which Northern Ireland but not the rest of the UK remains in the EU single market for goods, allow the maintenance of the open border between Northern Ireland and the Republic of Ireland. The establishment of the open border was a key aspect of the Northern Ireland Peace Process and Good Friday Agreement which ended the Northern Ireland Conflict. The Protocol instead creates a de facto customs border in the Irish Sea between Northern Ireland and Great Britain. Principally to address concerns of Ulster Unionists about the Protocol, in 2022-23 the EU and UK agreed revised arrangements for its operation – the Windsor Framework – which took effect on 24 March 2023. The Democratic Unionist Party declined to accept the Framework as meeting their concerns until further adjustments to its operation were agreed on 31 January 2024 and the formation of a new Northern Ireland Executive began.
Before the 1921 destruction of Tulsa’s Greenwood District, Black residents had created a remarkable center of business and community life. The district included stores, professional offices, entertainment venues and homes owned by Black citizens. Understanding Greenwood means learning what was built—not only what was burned.
MORE →The Greenwood District.