Civil Rights
Movements, leaders, victories and the continuing fight for equality.
Explore the people, places, events, achievements, struggles and stories that shaped our journey.
Movements, leaders, victories and the continuing fight for equality.
Innovation, patents, science, technology and world-changing contributions.
Pioneers, champions, Negro Leagues, records, activism and excellence.
Meet the people whose lives, choices and achievements shaped the journey.
Black towns, communities, institutions and places where history happened.
Moments that changed communities, movements, institutions and the nation.
Katherine Johnson’s mathematical calculations helped guide some of America’s most important early space missions while she confronted the racial and gender barriers faced by Black women in twentieth-century America.
MORE →Reflects the personal views, recollections, and perspective of the author, Mike Davis.
This is a personal recollection on the Move fire on May 13, 1985
| Introduced | January 1, 1985 |
|---|---|
| TLD type | Infrastructure domain |
| Status | Active |
| Registry | IANA |
| Sponsor | Internet Architecture Board |
| Intended use | A temporary TLD to facilitate the transition from ARPANET to the DNS. |
| Actual use | Internet infrastructure such as reverse DNS lookup. |
| Registration restrictions | No domain registrations possible, new subdomains rarely added |
| Structure | Second-level domains used for various functions related to Internet infrastructure as defined by RFCs. |
| Documents | RFC 3172; RFC 9120 |
| Dispute policies | None |
| DNSSEC | Yes |
| Registry website | IANA .arpa info |
The domain name arpa is a top-level domain (TLD) in the Domain Name System (DNS) of the Internet. It is used predominantly for the management of technical network infrastructure. Prominent among such functions are the subdomains in-addr.arpa and ip6.arpa, which provide namespaces for reverse DNS lookup of IPv4 and IPv6 addresses, respectively.
The name originally was the acronym for the Advanced Research Projects Agency (ARPA), the funding organization in the United States that developed the ARPANET, the precursor of the Internet. It was the first domain defined for the network in preparation for a hierarchical naming system for the delegation of authority, autonomy, and responsibility. It was originally intended only to serve in a temporary function for facilitating the systematic naming of the ARPANET computers. However, it became practically difficult to remove the domain after infrastructural uses had been sanctioned. As a result, the name was redefined as the backronym Address and Routing Parameter Area.
Domain-name registrations in arpa are not possible, and new subdomains are infrequently added by the Internet Engineering Task Force.
Each computer using the Internet Protocol is identified by a numerical IP address for identification and location addressing.[1] Each host is also assigned a more memorable hostname, which often relates to the purpose or ownership of the host, and is used more conveniently in user interaction with network functions, such as when connecting to or accessing a resource. Originally, the mapping between names and addresses was a cumbersome mechanical process using lookup tables distributed as computer files between network administrators. The Domain Name System (DNS) solved this inefficiency by automating the lookup function with a hierarchical naming system using domain names. When a user requests a network service using a domain name, the protocol implementation (protocol stack) translates the name to an address that can be used to reach a remote host.
This naming function, often called forward resolution, was the original purpose of the top-level domain "ARPA". It was the first domain defined in the first naming system of the nascent Internet,[2] and was supposed to be an initial container domain for all then-existing ARPANET hosts. The next stage of development of the naming architecture foresaw the establishment of specific domains for other purposes based on certain requirements.[2]
In many applications the reverse of the name-to-address mapping is also required. The host receiving a service request may require the domain name of the originating computer, for example, to customize the service, or for verification purposes. This latter function, called Reverse DNS lookup, is implemented in the major uses of the domain arpa: its subdomains in-addr.arpa for Internet Protocol version 4, and ip6.arpa for IPv6.
Conceptually similar lookup and mapping functionality is provided by other subdomains of arpa for specific types of data.
The domain e164.arpa provides a lookup function that retrieves information associated with telephone numbers through the ENUM service. This service may be used to obtain the name of a computer that is capable of routing telecommunication requests for a registered telephone number, or obtain an email address to contact the subscriber of a specific telephone number.
The domain name home.arpa was reserved by the Internet Engineering task force in May 2018 as a special-use domain name for non-unique DNS services in residential networking, to avoid the use of the top-level domain home., which would require DNSSEC signatures.[3] In addition, the use of home. led to domain name leakage to the Internet root name servers. The authoritative name servers for home.arpa are the AS112 blackhole servers,[4] which prevent leaked queries for home.arpa from burdening the root servers.[5]
The ARPANET, named for the Advanced Research Projects Agency (ARPA), was launched in 1969, and is considered the earliest predecessor of the Internet. The agency's name was adopted as the name for the first formal name space of the network after it had transitioned to TCP/IP networking in January 1983.[2] The name was used as a naming suffix for all then-existing ARPANET hosts. Hierarchical domain-style names were intended to support delegation of responsibility and authority for adding future hosts to the network.
With the formal development of such a hierarchical naming system, the domain also became one of the inaugural members of a set of domain names for specific types of network members, namely com for commercial users, org for organizations, edu for educational institutions, gov for government entities, and mil for networks of the United States military.[6]
It was expected that the use of arpa would be temporary and that the existing systems would be migrated to other domains.[6] But arpa also provided e-mail addresses associated with the Network Information Center, which administered the naming system. After serving the transitional purpose, it proved impractical to remove the domain. The domain in-addr.arpa had been installed for reverse DNS lookup of IP addresses.[7]: §3.5
Originally, the IETF intended that new infrastructure databases would be created in the top-level domain int. In May 2000, this policy was reversed and it was decided that the top-level domain int should be restricted to use by international organizations.[8] Arpa was retained for its long-standing purpose, but its full name was changed to the Address and Routing Parameter Area, making the zone name a backronym.[9]: 7 Registrations of internet infrastructure services in .int made prior to this policy change, were optionally grandfathered in and not required to move to .arpa.
In March 2010, zone arpa was secured with digital signatures within the Domain Name System Security Extensions (DNSSEC).[10]
Subdomains of arpa are created by resolution in the work groups of the Internet Engineering Task Force via the Request for Comments process, and are maintained by the Internet Assigned Numbers Authority (IANA). The DNS zone arpa has the following subdomains:[11][12]
| Domain | Purpose | Authority document (RFC) |
|---|---|---|
| 6tisch.arpa | For IPv6 over the Time Slotted Channel Hopping mode of IEEE 802.15.4 | RFC 9031[13] |
| as112.arpa | Sinking of DNS traffic for reverse IP address resolutions, misc. (see Blackhole server) | RFC 7535[14] |
| e164.arpa | Mapping of E.164 numbers to Internet URIs | RFC 6116[15] |
| eap-noob.arpa | For the Nimble Out-Of-Band authentication method of the Extensible Authentication Protocol framework | RFC 9140[16] |
| home.arpa | Residential networking | RFC 8375[3] |
| in-addr.arpa | Mapping of IPv4 addresses to domain names | RFC 1035[7] |
| ip6.arpa | Mapping of IPv6 addresses to domain names | RFC 3152[17] |
| in-addr-servers.arpa | Domains for authoritative DNS servers for the reverse lookup domains | RFC 5855[18] |
| ip6-servers.arpa | ||
| ipv4only.arpa | Detection of DNS64 availability and NAT64 prefix | RFC 7050[19] |
| iris.arpa | Locating Internet registry information services | RFC 4698[20] |
| ns.arpa | Domain for hosting authoritative DNS servers for the .arpa domain | RFC 9120[21] |
| resolver.arpa | Domain for discovery of designated DNS resolvers | RFC 9462[22] |
| service.arpa | For DNS-based service discovery over unicast | RFC 9665[23] |
| uri.arpa | Resolution of URIs and URNs, according to the Dynamic Delegation Discovery System |
RFC 3405[24] |
| urn.arpa |
Further, as indicated by DARPA, the arpa TLD string should be given a different expansion such as "Address and Routing Parameter Area" to avoid any implication that DARPA has operational responsibility for the domain.
(987)
Source: Wikipedia. Article content is retrieved live through the MediaWiki API.
The domain name arpa is a top-level domain (TLD) in the Domain Name System (DNS) of the Internet. It is used predominantly for the management of technical network infrastructure. Prominent among such functions are the subdomains in-addr.arpa and ip6.arpa, which provide namespaces for reverse DNS lookup of IPv4 and IPv6 addresses, respectively. The name originally was the acronym for the Advanced Research Projects Agency (ARPA), the funding organization in the United States that developed the ARPANET, the precursor of the Internet. It was the first domain defined for the network in preparation for a hierarchical naming system for the delegation of authority, autonomy, and responsibility. It was originally intended only to serve in a temporary function for facilitating the systematic naming of the ARPANET computers. However, it became practically difficult to remove the domain after infrastructural uses had been sanctioned. As a result, the name was redefined as the backronym Address and Routing Parameter Area. Domain-name registrations in arpa are not possible, and new subdomains are infrequently added by the Internet Engineering Task Force.
Task management is the process of overseeing a task through its lifecycle. It involves planning, testing, tracking, and reporting. Task management can help individuals achieve goals or enable groups of individuals to collaborate and share knowledge for the accomplishment of collective goals. Tasks are also differentiated by complexity, from low to high. Effective task management requires overseeing all aspects of a task, including its status, priority, time, human and financial resource assignments, recurrence, dependencies, notifications, etc. These can be lumped together broadly as the fundamental activities of task management. Managing tasks for multiple individuals or teams can be facilitated by specialized software, such as workflow or project-management software. Task management may be a component of project management and process management, serving as the foundation for efficient workflow within an organization. Project managers adhering to task-oriented management have a detailed and up-to-date project schedule and are usually good at directing team members and moving the project forward.
Business performance management (BPM) (also known as corporate performance management (CPM) enterprise performance management (EPM),) is a management approach that uses processes and analytical tools intended to assess the extent to which a business organization's activities and outputs align with its goals. BPM is associated with business process management, a larger framework managing organizational processes. Performance management may focus on the performance of an entire organization, a department, an employee, or the processes in place to manage particular tasks. Performance standards are set by senior leadership and task owners which may include expectations for job duties, timely feedback and coaching, evaluating employee performance and behavior against desired outcomes, and implementing reward systems. BPM can involve outlining the role of each individual in an organization in terms of functions and responsibilities.
Simple Network Management Protocol (SNMP) is an Internet Standard protocol for collecting and organizing information about managed devices on IP networks and for modifying that information to change device behavior. Devices that typically support SNMP include cable modems, routers, network switches, servers, workstations, printers, and more. SNMP is widely used in network management for network monitoring. SNMP exposes management data in the form of variables on the managed systems organized in a management information base (MIB), which describes the system status and configuration. These variables can then be remotely queried (and, in some circumstances, manipulated) by network management applications. Three significant versions of SNMP have been developed and deployed. SNMPv1 is the original version of the protocol. More recent versions, SNMPv2c and SNMPv3, feature improvements in performance, flexibility and security. SNMP is a component of the Internet Protocol Suite as defined by the Internet Engineering Task Force (IETF). It consists of a set of standards for network management, including an application layer protocol, a database schema, and a set of data objects.
Before the 1921 destruction of Tulsa’s Greenwood District, Black residents had created a remarkable center of business and community life. The district included stores, professional offices, entertainment venues and homes owned by Black citizens. Understanding Greenwood means learning what was built—not only what was burned.
MORE →Mae Jemison, aboard Space Shuttle Endeavour in 1992.